The Relias Platform is presently operational but running slowly

Incident Report for Relias Learning

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 15:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2026 - 14:29 EDT

Investigating

The Relias Platform is presently operational but running slowly
Posted Jun 08, 2026 - 12:48 EDT
This incident affected: Relias Platform, Compliance Management, Reports, Enrollments, Relias Assessments, API Services, and Other.